wc3campaigns
WC3C Homepage - www.wc3c.netUser Control Panel (Requires Log-In)Engage in discussions with other users and join contests in the WC3C forums!Read one of our many tutorials, ranging in difficulty from beginner to advanced!Show off your artistic talents in the WC3C Gallery!Download quality models, textures, spells (vJASS/JASS), systems, and scripts!Download maps that have passed through our rigorous approval process!

Go Back   Wc3C.net > Warcraft III Modding > Hosted Projects > AMAI
User Name
Password
Register Rules Get Hosted! Chat Pastebin FAQ and Rules Members List Calendar



Closed Thread
 
Thread Tools Search this Thread
Old 10-22-2004, 12:07 PM   #1
AIAndy
User


Respected User
 
Join Date: Oct 2002
Posts: 1,296

AIAndy is on a distinguished road (21)

Information FAQ

The following is an excerpt of the AMAI manual where an online version is available at http://www.hornes.pwp.blueyonder.co....ual/manual.htm

REQUIREMENTS

First you will of course need a copy of Blizzard's Warcraft 3 with or without The Frozen Throne expansion pack.

Current Supported Versions
RoC 1.17 or later (reccomend 1.21)
TFT 1.21

You will need a computer that meets Blizzards recommended system requirements for Warcraft 3 since AMAI will consume a bit extra CPU power and the minimum system requirements might not suffice for use with AMAI.

AMAI DEVELOPER EDITION REQUIREMENTS

To make own strategies it's also very helpful if you have some previous experience with programming of any kind.

You will need a program able to edit tables in form of tab separated text files if you are a campaign creator or for some other reason want to make AMAI work with custom units. Microsoft Excel is a good example of such a program.

You also need to have Perl installed on your computer in order to compile your AMAI and make use of the AMAI Editor to edit profiles and strategies. It's free and you can find it here. Do note install the 5.6.1.638 version as is not fully compatible and errors can occur.

Download and install it and then after rebooting your system you will be able to execute perl files (.pl) that are used for compiling AMAI and managing the strategies.


TECHNICAL SUPPORT
I double click the AMAIStrategyManager.pl a command window pops up but then nothing else happens?
The latest version of perl v5.10.0 doesn't have the tk gui bundled with it any more causing this problem. The easiest solution is to just download v5.8 thats still available at the perl site or you can use perl package manager(ppm) to add tk into v5.10

AMAI installer claims that it can't find some files and disables the install button.
In Player Edition, you likely unpacked the Zip without keeping the directories. That means you unpacked all files into one directory instead of having the directories like in the Zip.

Can i play in Battlenet after having installed AMAI ?
Yes, but in Player Edition be sure to use a subfolder installation to have the default unaltered maps to play on Battlenet and in the subfolder you can have the same maps but with AMAI in them.
If you have Simple Edition then just use the normal Exe instead of the AMAI one for playing ladder.

I installed AMAI Player Edition and i can't play in battlenet , why ?
You didn't used the subfolder installation suggested in the readme and ignored the warnings of the installer. To restore the maps open them in the world editor and save them there.

What is that subfolder thing you are talking about ?
(This does not apply to Simple Edition)
How about reading the readme file ?
To install AMAI properly and not breaking your battlenet experience :
Create a subfolder in your "maps" folder like "maps\AMAI" and -copy- the maps you intend to use AMAI with there, then start the installer "AMAI.exe".
After the installation of AMAI, on your "maps" folder all the maps will remain unaltered (and so not breaking your battlenet) and in the "maps\AMAI" subfolder you will have the same maps, but altered to support AMAI .

How do I use AMAI on a MAC?
Maps are archives (similar to e.g. zip). Files added there are used by Warcraft instead of the normal ones.
So what you need is a program that can access MPQs on a mac (There should be one on http://www.wc3sear.ch/index.php?p=Tools ).
Then add the scripts in the Scripts\TFT subfolder of AMAI (or Scripts\RoC for RoC) to the map that should use AMAI with that program. They should be in a Scripts subfolder of the map too. So common.ai goes to Scripts\common.ai .
For the Commander also add Blizzard.j from the Scripts folder to the Scripts folder of the map.
If you have a Windows computer at hand you can also use the AMAI installer on the Windows computer and copy the resulting maps to the mac.

I use AMAI Developer Edition but during compilation I get the following error message: "Unknown discipline ':utf8' at ejass.pl line 38."
UTF-8 is the encoding that Warcraft uses (it is a unicode derivate so it can encode characters of loads of languages). Unicode support is available in ActivePerl 5.6x, but has only been properly done since 5.8x so I suggest upgrading ActivePerl (there might be some way to make it work in 5.6x, but I am unsure what that requires).

How can I make profile specific chat lines ?
Use a condition on the name of the AI. Like
{Name=Aggressario}This chat line will only be used by the profile named Aggressario.

I get an error while compiling the Developer's Edition, what do i do?
First don't panic. Second, check which file the error is in and note the line number. In the compiled scripts find the file in question. Open it in notepad use the "go to.." command under edit to enter your line number. You can then see what is causing the error and hopefully that will help you in finding the source of the problem.

AMAI developer edition gives the following "'perl' is not a valid batch instruction or operation"
When installing perl you must check the "Add Perl to path environment variable" otherwise the developer edition will not work.

AMAI dosn't compile the scripts properly and appear blank but executable works fine?
You may be using 5.6.1.638 version of perl. Please make sure you update to a newer version of perl.

I added the default AMAI into my custom map but they dont build past tier 1
In your custom map Click Scenario - Map Options - Game Data set and change it to Melee (latest patch)
Custom (TFT 1.07) data set is currently not supported by the default AMAI.

Last edited by Strategy Master : 09-26-2008 at 04:53 PM.
AIAndy is offline  
Sponsored Links - Login to hide this ad!
Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 08:35 AM.


Affiliates
The Hubb The JASS Vault Clan WEnW Campaign Creations Clan CBS GamesModding Flixreel Videos

Powered by vBulletin (Copyright ©2000 - 2019, Jelsoft Enterprises Ltd).
Hosted by www.OICcam.com
IT Support and Services provided by Executive IT Services