wc3campaigns
WC3C Homepage - www.wc3c.netUser Control Panel (Requires Log-In)Engage in discussions with other users and join contests in the WC3C forums!Read one of our many tutorials, ranging in difficulty from beginner to advanced!Show off your artistic talents in the WC3C Gallery!Download quality models, textures, spells (vJASS/JASS), systems, and scripts!Download maps that have passed through our rigorous approval process!

Go Back   Wc3C.net > Warcraft III Modding > Developer's Corner > Cinematics
User Name
Password
Register Rules Get Hosted! Chat Pastebin FAQ and Rules Members List Calendar



Reply
 
Thread Tools Search this Thread
Old 01-20-2008, 04:02 PM   #1
loktar
User
 
loktar's Avatar
 
Join Date: Dec 2005
Posts: 23

loktar has little to show at this moment (2)

Send a message via MSN to loktar
Default Music and Ambient Volume

I'm trying to make a cinematic, and I want the music volume to be 100% and all other sounds 0%.

I have used the Set [sound] to x% for every type of sound available, but I still get ambient sounds (e.g. wind) that are louder than the music.
I've tinkered around quite a bit but I can't get it to work... any help would be appreciated.

Thanks,

loktar
__________________
loktar is offline   Reply With Quote
Sponsored Links - Login to hide this ad!
Old 01-22-2008, 11:45 AM   #2
BBDino
Wc3c's resident llama.
 
BBDino's Avatar
 
Join Date: Dec 2002
Posts: 944

BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)

Default

First check you're actually muting all the possible channels, it sounds redundant, but more often than not these sort of problems are simply the product of careless errors.

Next try and isolate exactly which channel is refusing to be muted. Some of them may have specific work arounds using imported corrupted sounds. If, for example, it turns out to be something like the ambient sound sets you can use Sound - Set Daylight Ambient Theme to a corrupted sound file for the duration you require silence.

If you can't isolate it and seem to be doing everything correctly... well i'm afraid I can't offer much help.
__________________
Say Yes! to stroking Llamas!
BBDino is offline   Reply With Quote
Old 01-22-2008, 02:46 PM   #3
2-P
la la la
 
2-P's Avatar


Terrain Moderator
 
Join Date: Jan 2006
Posts: 441

Submissions (14)

2-P is a glorious beacon of light (425)2-P is a glorious beacon of light (425)2-P is a glorious beacon of light (425)

Default

http://wc3campaigns.net/showthread.php?t=82062

Take a look at (copy) the Initialization Trigger. The two custom scripts at the end are what you're looking for.

Last edited by 2-P : 01-22-2008 at 02:46 PM.
2-P is offline   Reply With Quote
Old 01-22-2008, 10:50 PM   #4
loktar
User
 
loktar's Avatar
 
Join Date: Dec 2005
Posts: 23

loktar has little to show at this moment (2)

Send a message via MSN to loktar
Default

Thanks 2-P, that worked.
I'm having two other problems though:
There's a boat that's on fire, but I don't want the fire sound to be heard.
I've set the Fire sound channel to 0% with no success, and then I set all the sound channels to 0% with still no success.

Second problem is the music volume; it's way too quiet for some reason, even though I've got "Set music volume to 100%" and "Set Music to 100%" on.

I don't see any solution to these problems unless with custom scripts, of which I know next to nothing.

These are my triggers, just for clarity:
Sound - Disable dawn and dusk sounds
Sound - Set Ambient Sounds to 0%
Sound - Set Animation and Spell Sounds to 0%
Sound - Set Unit Movement Sounds to 0%
Sound - Set Fire Sounds to 0%
Sound - Set Combat Sounds to 0%
Sound - Set User Interface Sounds to 0%
Sound - Set Unit Response Sounds to 0%
Sound - Set music volume to 100%
Sound - Music to 100%
Sound - Clear the music list
Custom script: call StopSound(bj_nightAmbientSound,true,true)
Custom script: call StopSound(bj_dayAmbientSound,true,true)
Sound - Play [music]


Thanks :)
__________________

Last edited by loktar : 01-22-2008 at 10:55 PM.
loktar is offline   Reply With Quote
Old 01-23-2008, 12:50 AM   #5
BBDino
Wc3c's resident llama.
 
BBDino's Avatar
 
Join Date: Dec 2002
Posts: 944

BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)

Default

I had a suspicion is was the Ambient Audio tracks.

As for your second problem, if you don't need the fire noise at all in the map, i'd just use the sound editor to wipe it out entirely.
__________________
Say Yes! to stroking Llamas!
BBDino is offline   Reply With Quote
Old 01-23-2008, 09:49 PM   #6
loktar
User
 
loktar's Avatar
 
Join Date: Dec 2005
Posts: 23

loktar has little to show at this moment (2)

Send a message via MSN to loktar
Default

Well I didn't find how to wipe it out from the sound editor (except maybe by replacing it with an empty sound), so I just set the units' health back to 100%, not really necessary to see them burning anyway.

I still haven't managed to turn up the volume for the music though :( Pretty annoying.

Thanks again ^^

EDIT: Now it starts playing the music in the loading screen when it's finished loading, and begins from the start when the map starts... strange :s
EDIT2: I fixed that by adding it to the music list rather than just playing it with a trigger.
__________________

Last edited by loktar : 01-23-2008 at 10:14 PM.
loktar is offline   Reply With Quote
Old 01-23-2008, 09:56 PM   #7
BBDino
Wc3c's resident llama.
 
BBDino's Avatar
 
Join Date: Dec 2002
Posts: 944

BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)BBDino has a spectacular aura about (95)

Default

You could always use a basic sound editing program to modify the volume of the music and then add it back into the map.
__________________
Say Yes! to stroking Llamas!
BBDino is offline   Reply With Quote
Old 01-23-2008, 10:14 PM   #8
2-P
la la la
 
2-P's Avatar


Terrain Moderator
 
Join Date: Jan 2006
Posts: 441

Submissions (14)

2-P is a glorious beacon of light (425)2-P is a glorious beacon of light (425)2-P is a glorious beacon of light (425)

Default

Set the Looping Sound of the fire doodad to None in the object editor, that should do the job.


The music volume is always lower in cinematic mode, just play all your songs as sounds.

Quote:
Now it starts playing the music in the loading screen when it's finished loading, and begins from the start when the map starts... strange :s
That's because you're playing the music at map initialization. Use elapsed game time as event.
2-P is offline   Reply With Quote
Old 01-23-2008, 10:51 PM   #9
loktar
User
 
loktar's Avatar
 
Join Date: Dec 2005
Posts: 23

loktar has little to show at this moment (2)

Send a message via MSN to loktar
Default

Ah, elapsed game time did the trick. It also made playing the music as a sound work, which didn't before.

The fire thing didn't work. I'm not using the fire doodad though, it's fire emitting from a damaged boat. I tried setting the Unit Sound Set to none but that didn't work.
Doesn't really matter now though, with the music at full volume it doesn't interfere as much.

Thanks for all the help!
__________________
loktar is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 11:11 AM.


Affiliates
The Hubb The JASS Vault Clan WEnW Campaign Creations Clan CBS GamesModding Flixreel Videos

Powered by vBulletin (Copyright ©2000 - 2019, Jelsoft Enterprises Ltd).
Hosted by www.OICcam.com
IT Support and Services provided by Executive IT Services