Wc3C.net (http://www.wc3c.net/forums.php)
-   Tools (http://www.wc3c.net/forumdisplay.php?f=617)
-   -   Jass NewGen Pack v5d (http://www.wc3c.net/showthread.php?t=90999)

MindWorX 01-23-2007 03:57 PM

Jass NewGen Pack v5d
2 Attachment(s)
This distribution includes:
Attachment 25978- Grimoire (1.5)
- JassHelper (0.9.I.2)
- Grim Extension Pack (1.0b)
- PJass (1.0k)
- TESH (Unofficial update by Van Damm and Zoxc)
- Risc's Colorizer FINAL
- UMSWE (5.0)
- Reinventing the Craft (0.20)

All properly set to work together, the result is kind of a World Editor that uses PJASS to check for syntax errors and uses all of JassHelper features (OOP, libraries, etc) plus can use Grim Extension Pack's commands as well (object merge, import files, icon bordering, custom pathing for tiles, trigger merger ...). Not to mention that it uses grimoire's war3err for testing so you can test the map in a much better envornment that will show you the (thread) crash causes instead of letting them happen. Now it also comes with syntax highlighting for the trigger editor and all the benefits of the classic UMSWE. Risc's Colorizer adds a helper for colored tooltips to the object editor.

Does this tool contain viruses?

No, some antivirus tools just think it does due to the nature of this tool, that works by injecting its own code into the process of the WE. Most tools allow to setup an exception for such cases, some have to be turned off though (like Kaspersky)

Does this work for patch 1.23?

Yes, except for Grimoire's war3err/japi. If you need those too, then I'd suggest a dual install fo War3, one patched to 1.23 for bnet play and one patched to 1.21 for development.

Main credits should really go to PipeDream, then there's PitzerMike who made such great addons and then Vexorian who made jasshelper and bundled everything and of course SFilip for the syntax highlighting, Risc for the Colorizer and the UMSWE team.


3: Updated programs and added functionalities (better menu commands+ it is easier to add weu, all thanks to grimoire's new scriptable everything)

3a: nothing big just new users won't have to check the menus to correctly before saving the first time (Last time I didn't notice grimoire was actually using the registry to save the states of the menus)

3b: jasshelper0.9.8.4 and including the fix for crashing during first save of a map.

3c: jasshelper0.9.8.7, 3d: jasshelper0.9.8.8 , 3e: jasshelper0.9.8.9 3f: jasshelper0.9.9.3 , PJass 1.0h
3g: jasshelper0.9.9.3 , PJass 1.0h

4a: * Finally we have all the great Grimoire 1.3 and 1.4 stuff in Jass NewGen. That includes
* major war3err improvements
* jass debugging!!!
* profiling
* give your objects your custom rawcodes in the object editor
* speed up your test map runs like replays
* Then there's trigger syntax highlighting finally included
* A new grimex plugin that can merge trigger data
* And one that generates objects using vJass external calls (abilities, uints, etc.)
* And one that auto-borders icons and auto-converts mdl/bmp/tga/jpg files
* A small pjass update to version 1.0j too

4b: # Fixed a lot of possible NewGen startup problems
# Not inserted War3 CD is now reported
# Added possibility to make a double click on a map open it in NewGen instead of the normal editor.
# Object merger bug fixes and improvements.
# New Troubleshooting section in the Readme.

4c: > JassHelper, war3err etc. are now enabled by default
> Updated to JassHelper
> Pyw3jdebug included
> Invalid ExecuteFunc detection was broken, is now fixed
> Player teams are now properly assigned in the advanced test map configuration
> Fixed a bug with the ObjectMerger
> For people who have trouble with the exe files the we.bat and startwar3.bat files are included (they can be used alternatively to the exe files)

4d: < Updated to Grimoire 1.5 (1.21b fixes)
< Updated to JassHelper
< Repaired the 'Register Shell Extensions' option so that maps open in NewGen WE with a double click (-> disable and re-enable this option in the menu to fix it)
< Various Grimex bugfixes
< This should work better with the 1.21b patch than previous versions, although it isn't clear if all problems are gone now
< Warmachine and w3jdebug menu entries added

5a: = Stable 1.21b version of Grimoire (war3err crash fixed)
= Stable JassHelper 0.9.9.B
= UMSWE 5 as a NewGen plugin :D
= Major grimex bugfixes and improvements
= All Grimex tools are now lua-driven and scriptable
= Graphical tile picker for the 'edit tileset' feature
= Standalone version of w3jdebug that doesn't require python (Download the debugger here and unpack it into your NewGen directory)
= More documentation, use NewGenReadme.html as a starting point

5b: $ works for 1.22 (except war3err/japi)
$ most recent JassHelper included (0.9.E.0)
$ included Risc's Colorizer plugin that adds a colorizer to the object editor (if .NET 2.0 is installed)
$ fixed the broken japi testmap and instructions and added a japi menu item
$ added umswe's missing game interface strings
$ included info on antivirus trouble and dual installs for war3err/japi in troubleshooting section

5c: $ works for 1.23 (except war3err/japi)
$ most recent JassHelper included (0.9.G.1)
$ most recent TESH included (
$ included Reinventing the Craft (0.20)

5d: $ most recent JassHelper included (0.9.I.2)
$ Fixed some RtC related bugs.


This section contains a collection of reported problems and their solutions, so that you don't have to re-read the whole thread.

My antivirus software reports viruses, is this package infected?
No, some antivirus tools just think it is due to the nature of this tool, that works by injecting its own code into the process of the WE. Most tools allow to setup an exception for such cases, some have to be turned off though (like Kaspersky, see below). Here's a list of tools that have been reported to cause trouble with NewGen:
* Avira Antivir detects several of the files as trojans, you can choose ignore for the reports and whitelist those files later to fix the problem. (Extras\Configuration, activate export mode, under both Scanner\Scan\Exceptions and Guard\Scan\Exceptions add the offending files to the list)
* Kaspersky Antivirus also gives false alarm and it's not possible to effectively whitelist NewGen. You need to turn Kaspersky off to use NewGen (see several questions below).
* EZ Antivirus silently quarantines some files breaking the editor completely. You need to turn it off before even downloading the pack, but then you should be able to whitelist NewGen, once it's installed.
* Avast Antivirus reports false viruses. It is possible to whitelist NewGen in its configuration though.
* AVG reports false viruses and may silently delete required files. I don't know if you can set an exception in AVG.
* F-secure reports several false viruses but you can make it ignore the NewGen files.
* McAfee VirusScan Enterprise also detects some files as viruses but allows to set an exception for those.
Check the forums if you have trouble with your antivirus software and NewGen.

Can I use war3err and japi with the latest Warcraft III version?
No, the last version that Grimoire supports is 1.21b. All editor features will still work with later versions, but the ingame features like war3err, japi and the debugger wont. A dual installation of Warcraft III is suggested to be able use to the powerful features of Grimoire still. For a dual installtion you need to follow these steps:
1. Uninstall previous Warcraft III installations from your computer.
2. Make a fresh installation of Warcraft III.
3. Patch the new installation to 1.21b with the standalone patch that can be obtained from the Blizzard site
4. Copy the complete Warcraft III folder to a different directory, so you have a second installation.
5. Patch the first installation to the latest version through battle.net or the standalone patch.
6. Fire up regedit and change the values of "HKEY_CURRENT_USER\Software\Blizzard Entertainment\Warcraft III\InstallPath", "HKEY_CURRENT_USER\\Software\Blizzard Entertainment\Warcraft III\InstallPathX" and "Software\Grimoire\War3InstallPath" to the directory of the copy you made in step 4.
7. Now you're set up to use the first installation for regular battle.net play and the second installation for mapmaking.

World Editor crashes when trying to call JassHelper, what could be problem?
Make sure in Registry Editor that Grimoire's Warcraft install path points to the Warcraft folder which you are using to edit maps (the 1.21b installation in case of a dual install).
See the previous question for more details on the registry paths that need to be set.

I don't know how and where this must be installed and how to run it?
Just extract all files from the downloaded archive to an empty directory of your choice. Preferably don't install it directly into the Warcraft III directory, and don't overwrite the folder of a previous installation, old files might cause problems.
To use it, simply start NewGen WE.exe and NewGen Warcraft.exe.

Which operating systems are supported?
This pack works on Windows 2000 and XP testedly, Windows Vista also seems to work according to user reports. Older versions and Unix systems or Macintosh are not supported, however parts of this pack can work on other systems if used from the command line.

When I use the test map button, Warcraft III will start but return to the main menu instead of loading a map?
This can happen when your map uses vJASS code and you hit the test map button when the map is unsaved (*-symbol is shown in the title bar) or the map has been saved-as directly before testing the map.
Simply save your map before every test-run, so that it's fully compiled.

Windowed, OpenGL and War3err mode work fine with the test map button, but why is the test ai button not affected?
You can work around it with the menu command Grimoire\Test map configuration. It offers the same settings as the test ai configuration but works with the normal test map button.

A popup keeps telling me that i should save my map again, especially when working in the campaign editor, how to deal with it?
For the first time a map is saved this is normal, because the path of the map isn't known until then.
When you're editing maps from a campaign, however the path cannot be found because those maps are stored inside the campaign.
A workaround is saving a local copy of that map in the maps folder and working with that copy, then when the map is finished re-import it into the campaign.
You can also turn off the popup via the Grimoire\Disable first save warning menu item, in case you want to make basic edits to maps that don't use vJASS features.
Another possible reason are non-standard-ansi characters in the path of your map. On Windows systems of other languages like Russian or Chinese this can be the problem. Copy the map to a directory that contains only standard ansi characters to fix it.

Whenever i start the NewGen WE I'm told that it can't find my Warcraft directory or I need to select it in a browser dialog everytime. What's wrong?
The browse for directory dialog is normal if it's the frist time you are starting the NewGen pack.
If the browser pops up every time, one possible reason could be the lack of admin privileges on the machine.
Another possible reason for this is non-standard-ansi characters in your Warcraft installation path, like already described in the previous paragraph.
If all fails you can hardcode the path into findpath.lua by removing the -- from the line --path = "C:\\Warcraft III" and changing the path there.

Whenever i start the NewGen WE I'm told that an instance is already running, I need to insert the CD or to turn off Kaspersky. What's wrong?
Well, as the message already suggests, an instance of the editor may already be running.
If this is not the case another cause for this popup may be that you're using a patch prior to version 1.21b and do not have the Warcraft CD in your CD drive.
Some antivirus tools like Kaspersky antivirus also cause this popup. You need to disable those tools before running NewGen.
If you have Kaspersky Antivirus installed, follow these steps to get it working:
1. Remove your current NewGen installation.
2. Redownload the NewGen pack and extract it to a directory of your choice.
3. Reboot your computer.
4. Turn off Kaspersky (right-click in systemtray -> Exit) before running NewGen.
5. Start the NewGen WE.
Make sure you never try to run NewGen when Kaspersky is on, because it will permanently block it until you restart your computer.

When i start the NewGen WE, the Grimoire menus never appear, or only appear the first time that i start NewGen. The WE acts like a completely unmodded, normal WE, what's wrong?
Make sure you have patched your Warcraft installation to version 1.21.
Make sure you're not using a cracked WE. Mount the TFT mini image in daemon tools instead of using a crack if you must. Although some people have successfully used NewGen with a cracked WE it is not recommended.
If you're using Vista, try it under Windows XP, maybe it's a Vista problem.
A virus might be the root of the problem too, make sure your computer is clean.
Finally anti-virus, anti-spyware and firewall software can be causing the problem by blocking the changes that Grimoire makes to the WE. Try disabling such software temporarily.

The trigger editor gets random crashes or I get a message about an invalid pointer or similar in tesh.dll?
The syntax highlighter has problems with Window Blinds and maybe other window mods. Set an exception for the WE in Window Blinds or disable the tool while you're using NewGen. To add an exception open WindowBlinds -> settings tab -> change the look of an app -> add per application setting. There tell it to completly ignore NewGen. I believe that it's sufficient to add JassNewGenPack\bin\exehack.exe there but you might also have to add Warcraft III\worldedit.exe and/or Warcraft III\worldedit121.exe to fix the error.

Whenever I save any map, no matter what code it contains I get an unrecognized pjass error?
This problem isn't solved yet, any clues and hints are welcome.

(How to open and extract .7z files? )


MaD[Lion] 04-09-2007 09:31 PM

Is there a syntax highlighter for this extended language?

wyrmlord 04-09-2007 09:35 PM

You can use Vim with the jass.vim in Vex's signature.

MaD[Lion] 04-09-2007 10:24 PM

How to get Vim

PitzerMike 04-09-2007 11:50 PM

How to use google

MaD[Lion] 04-10-2007 11:32 AM

ok i got vim, but using it is like using dos with some cursor control. Dont like it much. Bad Gui. Besides i cant get it to work with jass.vim when i open a jass file, it works if i dont open. I was looking for some file type things, but couldnt find cus of it's bad way of navigation.

Vexorian 04-10-2007 02:52 PM

You can just use Sfilip's addon to have syntax highlighting in WE it is compatible with it.

You shouldn't try using gVim if you don't know that insert changes the "Bad DOS cursor" to the windows like one. bad way of navigation is senseless since it has got a menu bar. And to associate a file to the syntax you simply need to change the init script.

MaD[Lion] 04-10-2007 03:06 PM

like i know wat an init script is, and where to find for gvim, i know how to use insert, but wat i mean is just it looks weird, i dont like the font, and all these ~ stuffs on new lines. Well it just doesnt lok fancy.
But i would like to try to use it if i know how to implement the god damn jass.vim and the file type

Vexorian 04-10-2007 03:11 PM

1 Attachment(s)
No ~ for me, I think those appears if the text format is mixed (unix and windows linebreak at the same time)

Font is changeable.

Colors as well.

Haven't tries Sfilips world edit hack yet?

PipeDream 04-11-2007 10:37 AM

1 Attachment(s)
Folding (zfap) & auto complete (ctrl-n) -

MaD[Lion] 04-11-2007 01:02 PM

Vex your looks beautiful, how did u configure your vim?
A ye i tried the other one... its cool, but cant make my own colors. i dont like it's syntax colors.

But cant someone modify jass shop pro so we have the syntax too? cus it got a function library

Vexorian 04-11-2007 01:51 PM

I thought he added a way to customize the colors?

One color scheme similar to the one I am using right now is the vexorian.vim in my signature.

I have this in filetype.vim :

au BufNewFile,BufRead *.j                        setf jass

It associates files to jass.vim

And this is my _vimrc:


set nocompatible
source $VIMRUNTIME/vimrc_example.vim
source $VIMRUNTIME/mswin.vim
behave mswin

set diffexpr=MyDiff()
function MyDiff()
  let opt = '-a --binary '
  if &diffopt =~ 'icase' | let opt = opt . '-i ' | endif
  if &diffopt =~ 'iwhite' | let opt = opt . '-b ' | endif
  let arg1 = v:fname_in
  if arg1 =~ ' ' | let arg1 = '"' . arg1 . '"' | endif
  let arg2 = v:fname_new
  if arg2 =~ ' ' | let arg2 = '"' . arg2 . '"' | endif
  let arg3 = v:fname_out
  if arg3 =~ ' ' | let arg3 = '"' . arg3 . '"' | endif
  let eq = ''
  if $VIMRUNTIME =~ ' '
    if &sh =~ '\<cmd'
      let cmd = '""' . $VIMRUNTIME . '\diff"'
      let eq = '"'
      let cmd = substitute($VIMRUNTIME, ' ', '" ', '') . '\diff"'
    let cmd = $VIMRUNTIME . '\diff'
  silent execute '!' . cmd . ' ' . opt . arg1 . ' ' . arg2 . ' > ' . arg3 . eq

colorscheme vexorian
set gfn=Courier_New:h10:cANSI

map <F3> :w!<CR>
set backupdir=V:\vxdocs\tmp
set directory=V:\vxdocs\tmp
map <F4> ggVG"+y<CR>
set fileformats=dos,unix

set expandtab
set tabstop=4

I set vexorian.vim as default color scheme and Courier New as font. Also some maps by pipedream. F4 will instantly copy the whole file when you are in cursor mode (the one that is not insert nor replace).

I learned that if you divide the window you can press F4 in one section and it copies all the file but in the other section of the window you don't lose the cursor, very useful.

MaD[Lion] 04-12-2007 02:47 AM

a thank you for this :) nothing is better than having a pro helping :D

emjlr3 04-14-2007 10:30 PM

I thought this was going to be updated ?

Vexorian 04-15-2007 05:10 PM


Originally Posted by emjlr3
I thought this was going to be updated ?

Every single day something presented that prevented me from releasing it. But today is the time.

All times are GMT. The time now is 02:36 AM.

Powered by vBulletin (Copyright ©2000 - 2020, Jelsoft Enterprises Ltd).
Hosted by www.OICcam.com
IT Support and Services provided by Executive IT Services